[Speex-dev] TI C6416 compiling issue

Jim Crichton jim.crichton at comcast.net
Mon Jul 6 03:06:07 PDT 2009


Someone else just had this problem compiling for the C67xx.  The problem was 
caused by the EXPORT keyword that is present in some files in 1.2rc1, but 
not in 1.2beta3 (had been added in svn build 14797, April, 2008).  To fix 
it, just add the line:

"#define EXPORT"

in ti/config.h.  Jean-Marc, a patch is attached.

- Jim

----- Original Message ----- 
From: "Y Wang" <yw8187 at bristol.ac.uk>
To: <speex-dev at xiph.org>
Sent: Tuesday, June 30, 2009 7:30 AM
Subject: [Speex-dev] TI C6416 compiling issue

> Dear Sir
> I am a university student doing my dissertation, my project is about 
> secure
> voice in GSM, and I use speex for speech compression.
> My problem is I am not able to compile the TI CCS project which I
> downloaded from the official website. I have followed the instruction to
> modify the directory in .pjt, but I still get error. I tried both Debug 
> and
> Release mode neither works.
> the attachment are compiling log could you help me please since it is 
> kinda
> urgent.
> Many thanks.
> Bryan
> ----------------------
> Y Wang
> yw8187 at bristol.ac.uk


> _______________________________________________
> Speex-dev mailing list
> Speex-dev at xiph.org
> http://lists.xiph.org/mailman/listinfo/speex-dev
-------------- next part --------------
A non-text attachment was scrubbed...
Name: speex_15545_ti_config.patch
Type: application/octet-stream
Size: 321 bytes
Desc: not available
Url : http://lists.xiph.org/pipermail/speex-dev/attachments/20090706/14655984/attachment.obj 

More information about the Speex-dev mailing list