[vorbis] Re: ogg123

Frank Klemm pfk at fuchs.offl.uni-jena.de
Mon Oct 8 15:17:44 PDT 2001

On Sun, Oct 07, 2001 at 05:11:43PM -0400, Kenneth Arnold wrote:
> I'm forwarding this on to the Vorbis users list because though it was
> initially addressed to me it's not really a problem I can deal with
> (though I give a few suggestions and discussion below anyway, of
> questionable accuracy).
> This was initially from a query to me about ogg123 WAV to stdout, but
> upon reply I got this in addition to discussion about WAV outuput, so
> I've cut this out and will reply to his ogg123 concerns individually
> unless anyone has further discussion (I think we've discussed the
> issue on the list quite enough already).
> This is from Frank Klemm <pfk at fuchs.offl.uni-jena.de>. I'd suggest
> replies be CC-ed to him because judging from his response he is
> probably not on the list.
> On Mon, Oct 08, 2001 at 12:37:17AM +0200, Frank Klemm wrote:
> > I can't install newer versions of Ogg.
> > 
> > It's the only program which makes permanently problems. First I uninstalled
> > all Ogg Vorbis stuff. Then I install it from the CVS and it never works.
> > This also happens on several fresh installed distributions.
> CVS HEAD libvorbis is in active work (normally it shouldn't be, but
> AFAIK Monty oopsed and committed his in-progress work to the HEAD
> instead of a branch). Try the RC2 tarballs from vorbis.com before
> experimenting further on CVS. But I continue my reply because I don't
> think the build system is appreciably changed since RC2.
> > I was able only to install Ogg Vorbis on one system, after some patches, because the CVS
> > sources need ALSA, which I do not have.
> Only libao. If you do not have the ALSA headers (which are all that
> are needed anyway; you don't actually have to have ALSA installed),
> the configure script should disable compiling the ALSA plugin. 
I don't have installed ALSA.
This is no reason not to compile a codec.
A codec should be able to compile with a C compiler without Megabytes of
configure stuff. Otherwise there's something wrong with it.

> If it's not, then there is some problem in the build system at present. If
> the rc2 tarballs (from vorbis.com) don't work either, I'd start
> considering oddities on your own system.
The problem exists for more than 12 months. It's a permanently problem.
It is not a temporary bug in the CVS.

> > There seems to be something very dirty inside Ogg Vorbis.
> > Try to install Ogg Vorbis on a 100% Ogg Vorbis free system.
> > 
> > checking if the linker (/usr/bin/ld) is GNU ld... yes
> > checking whether the linker (/usr/bin/ld) supports shared libraries... yes
> [...]
> > checking dynamic linker characteristics... Linux ld.so
> > checking if libtool supports shared libraries... yes
> > checking whether to build shared libraries... yes
> > checking whether to build static libraries... yes
> > checking host system type... i686-pc-linux-gnu
> [...]
> > checking for Ogg... no
> > *** Could not run Ogg test program, checking why...
> > *** The test program compiled, but did not run. This usually means
> > *** that the run-time linker is not finding Ogg or finding the wrong
> > *** version of Ogg. If it is not finding Ogg, you'll need to set your
> > *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
> > *** to the installed location  Also, make sure you have run ldconfig if that
> > *** is required on your system
> > ***
> > *** If you have an old version installed, it is best to remove it, although
> > *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
> > configure: error: must have Ogg installed!
> > f:/home/cvs/vorbis # find /usr/ -name '*ogg*so*'
> > /usr/local/lib/libogg.so.0
> > /usr/local/lib/libogg.so.0.2.0
> > /usr/local/lib/libogg.so
> > f:/home/cvs/vorbis # echo $LD_LIBRARY_PATH
> > /usr/local/lib
> > f:/home/cvs/vorbis #
> It's possible that the test compile is not actually using
> LD_LIBRARY_PATH (i.e. something is setting it to a different value
> instead of appending to it) but that is unlikely at this point. Have
> your tried adding /usr/local/lib to /etc/ld.so.conf and/or checking
> config.log to ensure that it's not some other problem that the
> configure script happens to hit when trying to run the test program?
All tested. No usable results.
At least the error message is nonsense.

> > Before this the following was executed:
> > 
> >    cd ao; ./autogen.sh; make; make install; ldconfig
> >    cd ../ogg; ./autogen.sh; make; make install; ldconfig
> >    cd ../vorbis
> > 
> > I'm not the only one who has problems installing Ogg Vorbis,
> > most people try this once and then forget Ogg Vorbis forever.
> > 
> > It should be possible to install Ogg Vorbis from CVS with one command, not
> > with so much command in a proper order. And it should work.
> The xiph.org CVS method is by far the standard method for installing
> other programs from CVS. See probably 95% of SourceForge projects for
> backing on that. The script ./autogen.sh is specifically designed to
> prepare the tree for a build, and then the standard make and make
> install steps as for most any Linux software. The things that make Ogg
> Vorbis any more complicated is that there are a few more modules that
> have interdependancies (perhaps someone should add a small README /
> INSTALL file to CVS root if this is possible just giving the order of
> modules to build), but you seem to have figured that out, and that you
> must run ldconfig after each module (except the tools) is installed,
> which is perfectly reasonable for installing libraries, and you
> figured that out also. The install target could run ldconfig, but for
> various reasons, not limited to cleanly building on autobuilders for
> distributions like Debian (which all needed modules currently do
> without any problem), it does not.
> As for the install not working, that suprises me quite a bit. There
> were problems like this in the early days of Vorbis for a few users,
> but with the number of users so much larger now, the building is very
> much foolproof, and should have definately worked if you did indeed do
> what you say you did (which is, with a few minor cosmetic differences,
> the standard build procedure). The only thing I can think of at the
> moment, and a definate possibility, is an automake / autoconf bug on
> your system, because the build process from CVS relies heavily on
> these working correctly.
There at least 3 fully different systems where Ogg Vorbis can't be
installed. Common is, that the base installation is something around 24
months old and no "Yet Another Linux Sound System" is installed.

> For all those whom you say tried Vorbis and
> failed, why didn't they ask for help on the vorbis lists
> (vorbis at xiph.org, subscription information from Majordomo at xiph.org or
> at http://xiph.org) or IRC (#vorbis on the OpenProjects.net network)?
> There are many people out there with experience who can help. There
> also prebuilt packages for most common distributions (RPM and Deb),
> and the Vorbis libraries are already in the Debian archive and should
> be released with the next version and are installable with nothing
> more than 'apt-get install vorbis-tools' for the distributed tools
> (including oggenc and ogg123) or the libraries will be automatically
> installed by programs that depend on them, including parts of KDE.
No Debian please.

Software should be installed within 10 minutes. I don't want to study the
xxxth mailing list. Most software works in this way. And for updating 
15 software package (without personal patches) you still need one day.

If all software would behave like Ogg Vorbis this takes a month.

Frank Klemm

--- >8 ----
List archives:  http://www.xiph.org/archives/
Ogg project homepage: http://www.xiph.org/ogg/
To unsubscribe from this list, send a message to 'vorbis-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.

More information about the Vorbis mailing list