[Theora-dev] building from svn

John Kintree jkintree at swbell.net
Wed Sep 15 06:19:07 PDT 2004

After downloading libogg-1.1.tar.gz, libvorbis-1.0.1.tar.gz, and   
libtheora-1.0alpha3.tar.gz; building and installing them in that order, and 
trying the alpha3 theora encoder, I decided to try to build theora from svn.

Using svn to checkout theoratrunk worked ok.  The first time I tried to 
execute ./autogen.sh, it complained that I didn't have automake.  Mandrake 
10.0 comes with automake version 1.4.  So, I upgraded both automake and 
autoconf to the latest versions.

When I run ./autogen.sh now, this is the output I get.  

 [john at kjohn theora]$ ./autogen.sh
checking for autoconf...
checking for automake 1.6 or later... automake
checking for aclocal 1.6 or later... aclocal
checking for libtool... libtoolize
I am going to run ./configure with no arguments - if you wish
to pass any to it, please specify them on the ./autogen.sh command line.
Generating configuration files for theora, please wait....
/usr/local/share/aclocal/vorbis.m4:9: warning: underquoted definition of 
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
aclocal:configure.ac:39: warning: macro `AM_PROG_LIBTOOL' not found in library
  libtoolize --automake
  automake --add-missing
examples/Makefile.am:10: `CFLAGS' is a user variable, you should not override 
examples/Makefile.am:10: use `AM_CFLAGS' instead.
lib/Makefile.am:3: Libtool library used but `LIBTOOL' is undefined
lib/Makefile.am:3: The usual way to define `LIBTOOL' is to add 
lib/Makefile.am:3: to `configure.ac' and run `aclocal' and `autoconf' again.

[john at kjohn theora]$ make
make: *** No targets specified and no makefile found.  Stop.

I have already added the line "AC_PROG_LIBTOOL" to configure.ac, and still get 
the above output.  

More information about the Theora-dev mailing list