[Theora-dev] building from svn

Thomas Vander Stichele thomas at apestaart.org
Wed Sep 15 07:11:31 PDT 2004


On Wed, 2004-09-15 at 15:19, John Kintree wrote:
> After downloading libogg-1.1.tar.gz, libvorbis-1.0.1.tar.gz, and   
> libtheora-1.0alpha3.tar.gz; building and installing them in that order, and 
> trying the alpha3 theora encoder, I decided to try to build theora from svn.
> Using svn to checkout theoratrunk worked ok.  The first time I tried to 
> execute ./autogen.sh, it complained that I didn't have automake.  Mandrake 
> 10.0 comes with automake version 1.4.  So, I upgraded both automake and 
> autoconf to the latest versions.
> When I run ./autogen.sh now, this is the output I get.  
> <snip>
>  [john at kjohn theora]$ ./autogen.sh
> checking for autoconf...
> checking for automake 1.6 or later... automake
> checking for aclocal 1.6 or later... aclocal
> checking for libtool... libtoolize
> I am going to run ./configure with no arguments - if you wish
> to pass any to it, please specify them on the ./autogen.sh command line.
> Generating configuration files for theora, please wait....
>   aclocal
> /usr/local/share/aclocal/vorbis.m4:9: warning: underquoted definition of 
>   run info '(automake)Extending aclocal'
>   or see http://sources.redhat.com/automake/automake.html#Extending%20aclocal
> aclocal:configure.ac:39: warning: macro `AM_PROG_LIBTOOL' not found in library

--> this is saying that you don't have libtool.m4 in the path aclocal
looks for.  Are you sure you are using the latest revision ? AFAICT
autogen.sh fails when any of the autotools fail, and your run seemed to
progress further after this normally fatal error.

>   autoheader
>   libtoolize --automake
>   automake --add-missing
> examples/Makefile.am:10: `CFLAGS' is a user variable, you should not override 
> it;
> examples/Makefile.am:10: use `AM_CFLAGS' instead.

I'd like to fix this "bug" but I seem to remember not liking this fix. 
Anyway, I want to fix it anyway.  In any case, it's just a warning, and
you only get it with am 1.6

> lib/Makefile.am:3: Libtool library used but `LIBTOOL' is undefined
> lib/Makefile.am:3:
> lib/Makefile.am:3: The usual way to define `LIBTOOL' is to add 
> lib/Makefile.am:3: to `configure.ac' and run `aclocal' and `autoconf' again.

These are logical errors based on aclocal not finding libtool.m4
> </snip>
> I have already added the line "AC_PROG_LIBTOOL" to configure.ac, and still get 
> the above output.  

don't, it's not your problem.  My first guess would be that you compiled
one of the tools from source (For example, automake), and installed it
in a different prefix (for example, /usr/local)


Dave/Dina : future TV today ! - http://www.davedina.org/
<-*- thomas (dot) apestaart (dot) org -*->
what good are promises
if nobody honours them ?
<-*- thomas (at) apestaart (dot) org -*->
URGent, best radio on the net - 24/7 ! - http://urgent.fm/

More information about the Theora-dev mailing list