[Speex-dev] exiting with ogg.h missing

Shridhar, Vasant vasant.shridhar at harman.com
Wed Aug 10 09:33:52 PDT 2011

I ran into a similar problem.  The OGG lib and header files need to be in a standard location.  To get around this problem I passed the following options to the configure script.

--with-ogg-libraries=<libogg_root>/src/.libs --with-ogg-includes=<libogg_root>/include.

In this case I built libogg and left all of the files in the default place (so I just did make not make install).  

Hope this helps.

Vasant Shridhar

-----Original Message-----
From: speex-dev-bounces at xiph.org [mailto:speex-dev-bounces at xiph.org] On Behalf Of Luca Ottaviano
Sent: Wednesday, August 10, 2011 12:18 PM
To: Rony Nandy
Cc: speex-dev at xiph.org
Subject: Re: [Speex-dev] exiting with ogg.h missing

On mer, 2011-08-10 at 09:41 -0400, Rony Nandy wrote:
> Hi All,
>          I have downloaded libogg-1.3.0 along with speex.But,during 
> build speex is exiting with ogg.h missing.Any suggestions will be highly 
> appreciated.

IIRC, speexenc encodes your data into a speex stream which is
encapsulated into an OGG container, so you need to libogg to compile it.

Though, it has been ages since I've worked with it.
Luca Ottaviano <lcottaviano at gmail.com>

Speex-dev mailing list
Speex-dev at xiph.org

More information about the Speex-dev mailing list