[Speex-dev] building speex on macos x

Hugo Forss hugo.forss at swipnet.se
Tue Aug 16 05:57:36 PDT 2005


I am unable to build SpeexEnc on Mac OS X 10.2. At first it complained 
about not finding "getopt.h" which i solved by copying said file from 
"vorbis-tools/include/" to "speex/include/". As i tried once again to 
build i was given the following message:

	ld: Undefined symbols:

I also tried both the custom tar-ball and the installer package posted 
by Alain Aubord but with the same results.

This seem to have affected several people running bsd and solaris 
systems. I've not seen any complaints from Mac users however. After 
some research i found out that getopt_long is included with Mac OS 10.3 
or later.

I also noted the "HAVE_GETOPT_LONG" option within SpeexDec and 
SpeexEnc. I guess it is connected to the following output from the 
configure script:

	checking for getopt_long... no
	checking for getopt_long in -lgnugetopt... no

Had it been the case that getopt_long was _required_ i imagine the 
configure script would have complained. But now it seems i should be 
able to build without it.

I hope I'm not doing wrong in turning to the developers list to try and 
find a solution for all of us MacOS 10.2 users.

-- Hugo Forss

More information about the Speex-dev mailing list