[opus] 1.1 Much slower on Raspberry Pi

Stuart Marsden stuartmarsden at finmars.co.uk
Tue Dec 17 14:14:53 PST 2013


That is good to know and if therefore the true apples to apples comparison
is 0.9.14 at comp 10 and 1.1 at comp 5 then things are fine. My ears are
not good enough to hear the difference so for speed I would target comp 5
or lower.

I just did a quick test and 0.9.14 at comp 10 was 3.872
1.1 at comp 5 was 5.218

So if the output is comparable then we do in fact see a speed improvement.

Thanks for pointing this out. Is it documented? I admit I have only read
some of the documentation.

Best Regards,

Stuart Marsden

On 17 December 2013 23:50, Gregory Maxwell <gmaxwell at gmail.com> wrote:

> On Mon, Dec 16, 2013 at 5:03 AM, Stuart Marsden
> <stuartmarsden at finmars.co.uk> wrote:
> > I have just started trying Opus with a view to using it in a project. I
> am
> > interested in embedded hardware and tried it on the Raspberry Pi using
> the
> > raspbian distro.
> >
> > The version of libopus in the repos is 0.9.14. I installed this and tried
> > encoding 2 minutes of speech from a librevox recording. It managed this
> at a
> > respectable pace for complexity 10:
> Complexity 10 is new analysis code that didn't exist in prior
> versions, setting complexity 5 gets you basically the same analysis
> that the 1.0 version had.
> On x86 and modern arm cores with fast FPUs the other speedups are
> enough that complexity 10 is about the same speed in the old software
> or the new software (but with much higher and consistent VBR quality).
>  But on chips with slow FPUs the new analysis code is much slower, in
> particular because it has not been entirely converted to fixed point
> (e.g. in the fixed point builds) which is what I believe you're seeing
> here.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.xiph.org/pipermail/opus/attachments/20131218/bfb69896/attachment.htm 

More information about the opus mailing list