[opus] 1.1 Much slower on Raspberry Pi

Gregory Maxwell gmaxwell at gmail.com
Tue Dec 17 13:50:51 PST 2013

On Mon, Dec 16, 2013 at 5:03 AM, Stuart Marsden
<stuartmarsden at finmars.co.uk> wrote:
> I have just started trying Opus with a view to using it in a project. I am
> interested in embedded hardware and tried it on the Raspberry Pi using the
> raspbian distro.
> The version of libopus in the repos is 0.9.14. I installed this and tried
> encoding 2 minutes of speech from a librevox recording. It managed this at a
> respectable pace for complexity 10:

Complexity 10 is new analysis code that didn't exist in prior
versions, setting complexity 5 gets you basically the same analysis
that the 1.0 version had.

On x86 and modern arm cores with fast FPUs the other speedups are
enough that complexity 10 is about the same speed in the old software
or the new software (but with much higher and consistent VBR quality).
 But on chips with slow FPUs the new analysis code is much slower, in
particular because it has not been entirely converted to fixed point
(e.g. in the fixed point builds) which is what I believe you're seeing

More information about the opus mailing list