[CELT-dev] arecord pipe to celtenc just stops

Gregory Maxwell gmaxwell at gmail.com
Tue May 26 06:06:08 PDT 2009

On Tue, May 26, 2009 at 7:48 AM, Jean-Marc Valin
<jean-marc.valin at usherbrooke.ca> wrote:
> Paul Sykes a écrit :
>> Hi all,
>> Just found out about this codec and I'm really impressed.
>> I compiled celt-0.5.2.tar.gz on my desktop and tried out a few tests.  I
>> then did a native fixed point arm compile on my beagleboard which also
>> worked a treat.
>> Before I get started with the library I was trying to see if I could
>> grab some real time audio, encode it and write to a file using arecord
>> in conjunction with celtenc.  I tried this using the below command but
>> unfortunately the encoder just exists straight away with no errors,
>> anybody else tried this?
> Did you check that the problem isn't with arecord? I've had all kinds of
> issues with that? Note also that if you want to stream audio, you can
> just use celtclient.
>        Jean-Marc

Celtclient is a minimalist

Celtclient is part of the libcelt distribution but it isn't built by
the build system yet because it depends on libspeexdsp but nothing
else in the CELT distribution does.  You *must* have a recent version
of libspeexdsp installed (i.e. 1.2rc1) to use celtclient.

To build celtclient you can do this:

cd celt
./configure ; make
cd tools
gcc -I. -I../libcelt -g -o celtclient celtclient.c alsa_device.c -lm
-lasound ../libcelt/.libs/libcelt.a -lspeexdsp

To run:
$ ./celtclient
Usage ./celtclient plughw:0,0 remote_host local_udp_port remote_udp_port


More information about the celt-dev mailing list