[CELT-dev] arecord pipe to celtenc just stops

Jean-Marc Valin jean-marc.valin at usherbrooke.ca
Tue May 26 04:48:15 PDT 2009

Did you check that the problem isn't with arecord? I've had all kinds of
issues with that? Note also that if you want to stream audio, you can
just use celtclient.


Paul Sykes a écrit :
> Hi all,
> Just found out about this codec and I'm really impressed. 
> I compiled celt-0.5.2.tar.gz on my desktop and tried out a few tests.  I
> then did a native fixed point arm compile on my beagleboard which also
> worked a treat.
> Before I get started with the library I was trying to see if I could
> grab some real time audio, encode it and write to a file using arecord
> in conjunction with celtenc.  I tried this using the below command but
> unfortunately the encoder just exists straight away with no errors,
> anybody else tried this?
> arecord -t wav -c 2 -r 44100 -f S16_LE | celtenc - test.oga
> Recording WAVE 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz,
> Stereo
> Encoding 44100 Hz audio using stereo (93 bytes per packet)
> paul at x61laptux:~/src/celt-0.5.2/tools$ 
> thank you,
> Paul.
> _______________________________________________
> celt-dev mailing list
> celt-dev at xiph.org
> http://lists.xiph.org/mailman/listinfo/celt-dev

More information about the celt-dev mailing list