[Icecast] Re: Cannot build ices0/libshout2 on Mac OSX 10.4.2

Dan Stowell danstowell at gmail.com
Sun Dec 11 05:26:34 PST 2005


Hi -

Thanks to both of you for your answers. In the end I followed a hint
in Brendan's answer, which was to switch Fink to use the unstable
tree. (Of course, since I'm using quite a recent version of Xcode, it
makes sense that the compatibility hasn't made it to the stable tree
just yet.)

Installed ices0 & icecast2, and our radio stream is back up! Hooray!

Thanks
Dan


2005/12/11, Dan Stowell <danstowell at gmail.com>:
> Hi -
>
> I'm rebuilding my OSX system and I can't get ices0 to build - or to be
> more exact, can't get libshout2 to build.
>
> I started by using DarwinPorts, and icecast2 & libogg & libvorbis
> seemed to build OK. The install of ices0 then gave up at the libshout2
> config stage with output like this:
>
> [...]
> checking for libvorbis... ok
> checking for struct ovectl_ratemanage_arg... no
> configure: error: requisite Ogg Vorbis library not found
>
> Now, I found a thread on this list in July describing a similar
> problem: http://lists.xiph.org/pipermail/icecast/2005-July/009744.html
> - and suggesting that compiling with gcc 4 might be the cause. I'm
> probably compiling with gcc 4 since I have the very latest Apple
> Developer Tools installed. Can anyone confirm? Or provide a hint for
> how I might fix this?
>
> (I also tried uninstalling the libraries, reinstalling them via fink,
> and then manually building libshout2. Then I failed at the config
> stage, this time ending with
> checking for ogg_sync_init in libogg... configure: error: not found,
> maybe you need to set LD_LIBRARY_PATH or /etc/ld.so.conf
> )
>
> Thanks in advance for any advice you can give -
> Dan
> --
http://www.flatfourradio.co.uk


More information about the Icecast mailing list