[Icecast] Cannot build ices0/libshout2 on Mac OSX 10.4.2

Brendan Cully brendan at xiph.org
Sat Dec 10 16:20:10 PST 2005


On Sunday, 11 December 2005 at 00:14, Dan Stowell wrote:
> Hi -
> 
> I'm rebuilding my OSX system and I can't get ices0 to build - or to be
> more exact, can't get libshout2 to build.
> 
> I started by using DarwinPorts, and icecast2 & libogg & libvorbis
> seemed to build OK. The install of ices0 then gave up at the libshout2
> config stage with output like this:
> 
> [...]
> checking for libvorbis... ok
> checking for struct ovectl_ratemanage_arg... no
> configure: error: requisite Ogg Vorbis library not found
> 
> Now, I found a thread on this list in July describing a similar
> problem: http://lists.xiph.org/pipermail/icecast/2005-July/009744.html
> - and suggesting that compiling with gcc 4 might be the cause. I'm
> probably compiling with gcc 4 since I have the very latest Apple
> Developer Tools installed. Can anyone confirm? Or provide a hint for
> how I might fix this?
> 
> (I also tried uninstalling the libraries, reinstalling them via fink,
> and then manually building libshout2. Then I failed at the config
> stage, this time ending with
> checking for ogg_sync_init in libogg... configure: error: not found,
> maybe you need to set LD_LIBRARY_PATH or /etc/ld.so.conf
> )

I've built them just fine with fink on OS X.4.3, xcode 2.2. libshout
2.1 and ices0 are already packaged for fink unstable, so you shoudn't
need to build them by hand.


More information about the Icecast mailing list