[Icecast] Yp + chroot does not work

ACiDAngel list-icecast at rewtbox.de
Mon Sep 13 17:50:25 PDT 2004


Anyone recognized yet that the yp functions do not work toogether with
chroot enabled?
I'm running icecast2 and it successfully announces to yp servers if i don't
have the chroot enabled.
Then i do nothing else than enabling chroot and the log says:

[2004-09-14  00:07:59] DBUG geturl/curl_print_header_result SID -> ()
[2004-09-14  00:07:59] DBUG geturl/curl_print_header_result Message -> ()
[2004-09-14  00:07:59] DBUG geturl/curl_print_header_result Touch Freq ->
(0)
[2004-09-14  00:07:59] DBUG geturl/curl_print_header_result Response -> (0)
[2004-09-14  00:07:59] EROR yp/yp_submit_url Got a NAK from yp_add(Unknown)
(http://dir.xiph.org/cgi-bin/yp-cgi)

The same yp directory worked before with non-chroot (also other directories)

I tried to figure out the problem - i thougt maybe ist a library problem -
maybe it fails to link to libresolv or so ...

So I tried to strace/ltrace the icecast2 process but it gave me no errors.
Does anyone has an solution for that problem because i dont want to run my
server without chroot for security reasons but i also would like to announce
to yp's.

I'm using the latest icecast version 2.0.1

And also some other question - how can I let icecast announce itself to
shoutcast YP directory (yp.shoutcast.com)
What is the url I have to use - just http://yp.shoutcast.com without
/cgi-bin/ stuff ?? 

Thanks 4 your help
Ralf




More information about the Icecast mailing list