[icecast] ices & savefile

Matt Trim matt at sv.net.au
Tue Aug 5 08:56:37 PDT 2003



> > [2003-08-06  01:11:09] DBUG input/open_next_input_module checking module 1
> > [2003-08-06  01:11:09] INFO input-oss/oss_open_module Opened audio device
> > /dev/dsp at 1 channel(s), 44100 Hz
> > [2003-08-06  01:11:09] EROR input-oss/oss_read Error reading from audio
> > device: Resource temporarily unavailable
> > [2003-08-06  01:11:09] INFO input/input_loop Closing input module
> > [2003-08-06  01:11:09] INFO input-oss/oss_close_module Closing OSS module
>
> odd, the open and the parameter settings succeeded but the read reported
> not yet. What sound card is it, kernel release etc?

Linux 2.4.20-8
Multisound Pinnacle (msnd_pinnacle)
(default Redhat 9.0 OSS sound driver)

> ok, a good thing to check for.  make sure nothing else is using the
> device though, fuser -v /dev/dsp can help to identify such issues.  The
> process for reading the audio isn't that much different, any setup
> errors would of been reported.

came up with nothing (just returned me to a prompt) which I guess means
that nothing was using /dev/dsp  I tried running it while ices was using
/dev/dsp and it found ices so fuser is working ok..

All I can think of is some incompatibility with my oss driver for the
pinnacle that has somehow presented itself - have you changed the code at
all that calls the oss sound driver?

Let me know if you need further info.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list