[icecast] Difficulties with Ices2

Karl Heyes karl at xiph.org
Tue Aug 5 14:30:54 PDT 2003



On Tue, 2003-08-05 at 21:22, Matthew Fields wrote:
> I have been successful in running a playlist through Ices and Icecast...
> I have run into difficulty running a live stream through the soundcard,
> however...
> 
> The following is the log when I attempt to run ices ices-mylive.xml:
> 
> INFO ices-core/main ices started...
> EROR input-oss/oss_open_module Couldn't set sample format to AFMT_S16_LE
> EROR input/input_loop Couldn't initialise input module "oss"
> INFO ices-core/main Shutdown complete

It's saying it failed to initialise the driver. This maybe due to some
limitation of the hardware/driver with respect to the specified
samplerate.  Try 11025 or some other common one like 22050 or 44100 and
resample to the wanted rate.

>         <input>
>             <module>oss</module>
>             <param name="rate">11000</param> <!-- samplerate 22050 best-->
>             <param name="channels">1</param> <!-- number of channels -->
>             <param name="device">/dev/dsp</param> <!-- audio device -->
>             <param name="metadata">0</param>
>             <param name="metadatafilename">test</param>
>         </input>

Set metadata to 1 if you want the metadata to be read from the file.

karl.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list