[vorbis-dev] new DLL additions in core libs
segher at chello.nl
Wed Sep 12 13:14:00 PDT 2001
Kenneth Arnold wrote:
> On Wed, Sep 12, 2001 at 12:42:39PM -0700, Segher Boessenkool wrote:
> > I think the cleanest (and most "correct") solution would be to separate
> > libvorbis (and libogg) into separate encoding and decoding parts, and
> > then to put the current libvorbisenc into the encoding part split off
> > the current libvorbis.
> > Oops, that's quite a bit of work...
> ... and duplication of code.
Not much, really, IMHO.
> Many of the operations use similar structures and share functionality;
Which is not the smart thing to do, especially when viewed from my
perspective (the optimization angle).
> you'll see a few functions like
> _vds_shared_init that just get a flag indicating whether it is encode
> or decode, and do mostly the same thing in either case. I'm not sure
> exactly how much code actually works like that.
This kind of coding makes for code that's hard to read, and error-prone.
Funny that you mention _vds_shared_init() in this context.
> You're sure that you can't have a function that returns a pointer to
> the shared area? I guess that would accomplish the same thing as
I'm not a win32 expert. But even on un*x, separating the library
into a libvorbisdec and a libvorbisenc seems to make more sense than
our current situation.
I'm not saying that we should restructure because win32 seems to have
some stupid limitations; I'm saying that we might as well try to do
The Right Thing(tm).
--- >8 ----
List archives: http://www.xiph.org/archives/
Ogg project homepage: http://www.xiph.org/ogg/
To unsubscribe from this list, send a message to 'vorbis-dev-request at xiph.org'
containing only the word 'unsubscribe' in the body. No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.
More information about the Vorbis-dev