[vorbis-dev] building libao under Debian

Jeremy C. Reed reed at reedmedia.net
Mon Apr 23 11:19:52 PDT 2001

Here are some of my notes with building and using vorbis-tools-1.0beta4
under Debian Linux 2.2.

1) building libao:

make[3]: Leaving directory
Making all in arts
make[3]: Entering directory
/bin/sh ../../../libtool --mode=compile gcc
-I. -I.  -I../../.. -I../../../include    -I/usr/include/kde/artsc -c
gcc -DPACKAGE=\"libao\" -DVERSION=\"0.6.0\" -DSIZEOF_SHORT=2
-I. -I. -I../../.. -I../../../include -I/usr/include/kde/artsc -c
ao_arts.c  -fPIC -DPIC -o ao_arts.lo
ao_arts.c:29: artsc.h: No such file or directory
make[3]: *** [ao_arts.lo] Error 1
make[3]: Leaving directory `/home/jeremy/src/ogg/libao-0.6.0/src/plugins/

Worked around this problem by commenting out "arts" in
SUBDIRS = oss esd alsa #arts # solaris irix

./configure said:
checking for artsc-config... /usr/bin/artsc-config


libvorbis and vorbis-tools's ./configure said:
 checking for Ogg... no
 *** Could not run Ogg test program, checking why..

Worked around that problem with:
 LD_LIBRARY_PATH=/usr/local/lib ./configure

I didn't look to closely, but I think it should use the default
(/usr/local/lib) with `-Wl,--rpath -Wl,/usr/local/lib' flag, so
LD_LIBRARY_PATH doesn't have to be set. (But I may be wrong.)


After installing vorbis-tools, oss wouldn't work. So I changed /dev/dsp to
/dev/audio in the libao source libao-0.6.0/src/plugins/oss/ao_oss.c and it

   Jeremy C. Reed

--- >8 ----
List archives:  http://www.xiph.org/archives/
Ogg project homepage: http://www.xiph.org/ogg/
To unsubscribe from this list, send a message to 'vorbis-dev-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.

More information about the Vorbis-dev mailing list