[theora] ffmpeg2theora bug: generation of a video from a series of images

sdaau sd at imi.aau.dk
Mon Aug 9 06:52:18 PDT 2010

Hi all,

Good I found this list has a (read-only) newsgroup interface in gmane - 
so hopefully I'm replying with the right thread headers :)

> On 03/05/2010 09:13 AM, Basil Mohamed Gohar wrote:
>> On 03/05/2010 01:26 AM, Michael Opdenacker wrote:
>>> Hi J.,
>>> We are using ffmpeg2theora to produce an introduction video from a
>>> series of images:
>>> ffmpeg2theora-0.26.linux32.bin images/img-%03d.png -o intro.ogv
>>> The video that we get is huge and horrible, with lots of blinking colors:
>>> http://free-electrons.com/issues/ffmpeg2theora-mar5-2010/intro.ogv
>>> Here's what we had in the past:
>>> http://free-electrons.com/issues/ffmpeg2theora-mar5-2010/intro-correct.ogv
>>> This issue was introduced in ffmpeg2theora-0.25, and a work-around is to
>>> revert to ffmpeg2theora-0.24
>>> [snip]
> Okay, I just ran all the PNG images through optipng after noticing
> that they had an alpha channel.  Also, ffmpeg reported they were in
> bgra format (the "a" is for alpha, but I don't know why they were
> bgr order).  I ran it through png2theora again, after this lossless
> (for the purposes of this test) processing, and I got a smaller video
> file without the corruption.  So, my first advice to you is to run
> the images through optipng and try again.

I would just like to say, that I tried this - and optipng doesn't seem 
to be the solution.

So I produced "a script that produces non-optimized (and then optimized) 
PNG's on the fly, and then uses ffmpeg2theora to encode them to videos; 
which demonstrates there may a bug with ffmpeg2theora 0.27, when using 
it to make videos of a PNG image sequence", which can be found in the 
second post in this thread:

10.04: Video overlay/composite editing with Theora ogv

I have included the results I get when running the script, as comments 
at the end of the script:"

# For both converted and non-converted pngs, 0.24 shows OK videos; 0.27 
shows extra colors for both;
# for all videos, vlc says:
# vlc (command line): "swScaler: pal8 is not supported as output pixel 

And all this is with the latest source of ffmpeg and theora (maybe some 
week old)

Could anyone please look into this problem a bit more closely? Or should 
I try to file a bug somewhere (if so, where?) I'd love to be able to use 
the latest ffmpeg2theora - also with PNG image sequence :)


More information about the theora mailing list