[theora] ffmpeg2theora: issue converting from a png image list

Michael Opdenacker michael at free-electrons.com
Wed Jul 15 14:24:03 PDT 2009

Hi Jan, all

I am trying to generate a video introduction with a fade-in / fade-out
effect. To do this with ffmpeg2theora only, I generated a list of PNG
images: img001.png, img002.png... img299.png

The ffmpeg2theora man page says:

Encode a series of images:
         ffmpeg2theora frame%06d.png -o output.ogv

That's exactly what I tried with the latest 0.24 release of ffmpeg2theora:

ffmpeg2theora-0.24.linux32.bin img-%03d.png -o output.ogv
Input #0, image2, from 'img-%03d.png':
  Duration: 00:00:12.00, start: 0.000000, bitrate: N/A
    Stream #0.0: Video: png, yuv420p, 1280x720, 25 tbr, 25 tbn, 25 tbc
  Resize: 1280x720
Segmentation fault

The same problem happens with the release in Ubuntu 9.04, and with the
0.22 release. I haven't tried earlier releases yet.

To reproduce this issue, you can get the images from the tarball on

I would like to avoid using mencoder + ffmpeg2theora to do the job
(unless I manage to generate the theora video directly from mencoder).

I hope this helps to fix this issue... Don't hesitate to get back to me
if you have any question.



Michael Opdenacker, Free Electrons
Kernel, drivers and embedded Linux development,
consulting, training and support.
+ 33 621 604 642

More information about the theora mailing list