[theora] Building Libtheora Beta 2 in Ms Visual C++ 2005 problems

Charles Mason charlie.mas at gmail.com
Mon Oct 22 02:42:59 PDT 2007

Hi All,

I have been using a slightly modified version of libtheora (from about
a year ago) and since libthoera is now reached BETA 2 I thought it
would be time to update. My application worked fine with that version
of libtheora.

So now I am trying to build libtheora beta 2 in Ms Visual C++ 2005 and
I am having a few problems. When I try to compile it I get the error

 You are compiling theora without inline assembly.
 This is probably not what you want.  Instead, please either
  (1) download the assembly .lib binaries or
  (2) compile them yourself using MinGW, and make Visual Studio
 link against them.
  Please seriously consider this before defining TH_REALLY_NO_ASSEMBLY
  to disable this message and compile without inline assembly.
  Thank you!

So as you may expect I immediately defined TH_REALLY_NO_ASSEMBLY, and
managed to get it to compile. The problem is when I try to decode a
Theora frame the yuv_buffer output seems completely uninitialised,
despite the decoder function returning the success flag.

The application worked fine with the alpha I was using before. When I
built the alpha libtheora build however I never got the above error.
So I suspect that the error is right and I don't want to compile
without inline assembly, I suppose I should listened in the first
place :).

I am not too clear on what exactly the "Inline Assembly" is. From what
I can find through Google its some sort of hand written assembler
optimisations. Option 1 in the error message sounds like the simplest
option to me, but I can find no download for these .libs.

So can someone explain what's going on and what I need to do to get
libtheora to build and work on windows.

Charlie M

More information about the theora mailing list