[Speex-dev] strange encode/decode results on C54x

Michael Jacobson Michael.Jacobson at ultratec.com
Fri Aug 3 07:05:55 PDT 2007

I currently have speex "working" in my project but the encode and the
decode don't seem to be working like I would hope.  I am using speex
1.2beta2 and I am trying to 16bit 8kbs narrowband.
on the decode side I encoded a voice on a windows machine.  I took the
encoded information and transferred it over to the C54x project and
decoded it and it didn't sound that great.  I watched the decode process
and it would appear that the first 40 of the 160 words (2 bytes) are all
0.  this means that every 20ms there is 5ms of silence which is what I
believe is causing our poor decode quality or at the very least an
indicator that something isn't right.  the submode is set to 3 so I
don't think it thinks it's in another mode.  I know that the decode on
the windows machine doesn't do this because the output file for the
windows machine is continuous data after the first 160 0's.  it seems to
me like it decodes part of it, but then doesn't decode the rest.  if you
would like the encoded file and the output please let me know.
on the encode side I encoded a few seconds of voice using my C54x
platform and tried to decode it on windows. the resulting decode
produced a voice that sounded much like the C54x decoded voice that was
encoded by windows (bad).  I will provide the encoded data to anyone who
wants it.  I don't notice any pattern of 0's in the decode or anything
like that.  I want to say that it's the sample rate that is causing the
problems but when the G729A ran at this rate it worked quite well.
if there is anything that you can do to help I would really appreciate
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.xiph.org/pipermail/speex-dev/attachments/20070803/0d89693a/attachment.htm

More information about the Speex-dev mailing list