[Speex-dev] AEC on a TI C6x - has no effect

Jean-Marc Valin jean-marc.valin at usherbrooke.ca
Tue Aug 15 07:52:32 PDT 2006

Itay Chamiel a écrit :
> Hi Jim,
> I've tried both 11343 and 11398 (after fixing a couple of compiler
> errors) and annoyingly enough I get the same results as the current
> build: float works, fixed doesn't. I also saw the same phenomenon where
> the st->W and st->PHI arrays are all zeroes in fixed point mode.
> I'm still optimistic though, as you've seen the same problem I've seen.

Check if Jim email solves the problem. Otherwise, can you test the
trivial case where you send the same data for the mic and the echo? Does
it cancel anything?


> Thanks,
> -itay
> ________________________________
> From: Jim Crichton [mailto:jim.crichton at comcast.net] 
> Sent: Tuesday, August 15, 2006 3:39 PM
> To: Itay Chamiel; speex-dev at xiph.org
> Subject: Re: [Speex-dev] AEC on a TI C6x - has no effect
> Itay,
> I tested on C6x in May with build 11343 and 11398, and it worked fine.
> I just ran the same test with build 11768, and there was no
> cancellation, just as you saw.  I will try to track this down in the
> next day or two.  In the meantime, I suggest that you try testing with
> 11398.
> - Jim
> _______________________________________________
> Speex-dev mailing list
> Speex-dev at xiph.org
> http://lists.xiph.org/mailman/listinfo/speex-dev

More information about the Speex-dev mailing list