[Speex-dev] AEC on a TI C6x - has no effect

Jim Crichton jim.crichton at comcast.net
Tue Aug 15 05:39:09 PDT 2006


I tested on C6x in May with build 11343 and 11398, and it worked fine.  I just ran the same test with build 11768, and there was no cancellation, just as you saw.  I will try to track this down in the next day or two.  In the meantime, I suggest that you try testing with 11398.

- Jim
  ----- Original Message ----- 
  From: Itay Chamiel 
  To: speex-dev at xiph.org 
  Sent: Monday, August 14, 2006 10:56 AM
  Subject: RE: [Speex-dev] AEC on a TI C6x - has no effect

  Thanks to a tip from Jean-Marc, I tried the floating point version and it worked well.

  If anyone has a clue as to why the fixed point version doesn't work, let me know as I would really appreciate the CPU time reduction (20% as opposed to 70%).




  Speex-dev mailing list
  Speex-dev at xiph.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.xiph.org/pipermail/speex-dev/attachments/20060815/fdd69035/attachment.html

More information about the Speex-dev mailing list