[paranoia] [Bug report] not possible to use cdparanoia with grip

MARNE Bertrand bmarne at free.fr
Thu Nov 11 08:09:55 PST 1999


I'm a linux user (Mandrake 6.1) and i have problems using cdparanoia with grip
(a graphic front-end for cdparanoia, cdda2wav, bladeenc, lame... for ripping
and Mp3 encoding Audio CD).

I was using cdparanoia in a personnal bashscript for ripping my Audio CD for
month when i discovered a graphic frontend for that job named grip

I never had problems with cdparanoia (GREAT softawre indeed) before using
grip... When i tried grip, cdparanoia never worked fine !
I joined the logs of my tests with this mail:
-On one hand, with my own bashscript (i also joined my *very basical* script)
-On the other hand, with grip, using cdparanoia (i have the same results using
internal cdparanoia of grip)... I tried several versions of grip (2.5 to 2.7
with the same results).

As my script was working fine, and grip was not, i tried to know what difference
there was in cdparanoia commandlines... There is one in particular i remarqued:
-In my script i execute "cdparanoia" (/usr/bin/ is not necessary as it is in the
-In grip "/usr/bin/cdparanoia" is executed...

So i tried to modify my script replacing  "cdparanoia" with
Then, my script failed and i had the same errors i had with grip... So it
seems that cdparanoia work correctly when his binary-path is NOT given !

I looked if there was several "cdparanoia" exectuable binary files (or links) on
my box, and i only find one, in /usr/bin...
I also tried several versions of cdparanoia (IIIa 6.5 to IIIa 6.9) without any
good results....

Do you know why i need to launch cdparanoia WITHOUT his path (that is
unfortunately not possible in grip) to have acccess to CDDA command set of my
CD driver (PHILIPS CDD 2600 SCSI) and to perform a ripping sequence ?

Best regards,

MARNE Bertrand

PS: please forgive my -VERY- poor english speaking !

<LI>application/x-shellscript attachment: My bashscript to rip (with cdparanoia) and Mp3 encode audio CD
-------------- next part --------------
A non-text attachment was scrubbed...
Name: CDtoMP3.bash
Type: application/octet-stream
Size: 378 bytes
Desc: not available
Url : http://lists.xiph.org/pipermail/paranoia/attachments/19991111/505b3f88/CDtoMP3.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: EngLogsCdparnoia.txt
Type: application/octet-stream
Size: 9844 bytes
Desc: not available
Url : http://lists.xiph.org/pipermail/paranoia/attachments/19991111/505b3f88/EngLogsCdparnoia.obj

More information about the Paranoia mailing list