[Icecast] [Icecast-dev] metadata fallback mounts

Andy Woolley andy at milonic.com
Thu Jan 19 02:11:53 PST 2006


karl wrote:
> from the description, it sounds like it is doing what it's supposed to be 
> doing, but the listening client is buffering a large amount of the sent 
> stream data.  The player will have a buffer, verify what setting that is 
> at and what the stream stream bitrate is.

Seems this is the answer, it's working but there is a 4-5 minute delay 
caused by a buffer once the fallback returns to the stream

This then puts the stream 4-5 minutes behind when it finally starts up.

Is there anything server side that I can change to make the time gap 
shorter?

Regards,
Andy


----- Original Message ----- 
From: "Karl Heyes" <karl at xiph.org>
To: "Andy Woolley" <andy at milonic.com>
Cc: <icecast at xiph.org>
Sent: Tuesday, January 17, 2006 11:11 PM
Subject: Re: [Icecast] [Icecast-dev] metadata fallback mounts


> Andy Woolley wrote:
>> Have now set the log to level 4 and viewed the output when the stream 
>> stops/starts.
>>
>> Can't see any errors though. I'm getting:
>>
>> source/source_move_clients passing 1 listeners to "/fallback.mp3"
>>
>>   on stream stop and:
>>
>> source/source_move_clients passing 1 listeners to "/studio"
>>
>>   when the stream starts again, so looks like it's working.
>>
>> Could it be the client at fault?
>>
>> Also, I did notice that sometimes (very occasionally) it will actually 
>> work but takes about 3 to 4 minutes to action. I tried the test again but 
>> it doesn't work every time only works occasionally.
>
> from the description, it sounds like it is doing what it's supposed to be 
> doing, but the listening client is buffering a large amount of the sent 
> stream data.  The player will have a buffer, verify what setting that is 
> at and what the stream stream bitrate is.
>
> karl. 



More information about the Icecast mailing list