[Icecast] Path to 'myauth' etc. files....

Chris Nighswonger cnighswonger at foundations.edu
Sun Dec 17 22:10:04 UTC 2006

We have been running Icecast for quite a while (over a year) on a
windows platform. No problems there. Last week we switched over to
Fedora. On the windows platform, the *auth files were in the root of
the icecast install directory along with icecast.xml and the binary.
On *nix the binary is in /usr/local/bin while the icecast.xml is in
/etc. So, I moved the *auth files to the /etc and the authentication
broke. I then placed a copy in the /usr/local/bin directory and it was
still broke. I then placed a copy in the /usr/share/icecast/admin.
Then the authentication worked. So I removed the other copies.... and
the authentication stopped working. Put them back... it worked....????
I have checked permissions. Everybody is icecast:icecast. The daemon
starts as root and does a chown to icecast per the icecast.xml file
So, the simple questions: What is the correct pathing to the *auth
files on a *nix install of icecast?


Chris Nighswonger
Network & Systems Director
Foundations Bible College & Seminary

More information about the Icecast mailing list