[Icecast] Stalled response from icecast to ices

Rolf Johansson rojo at nocrew.org
Tue Mar 29 14:47:52 UTC 2005

Icecast 1.3.12
IceS 0.3
Linshout 2.0/2.1 tried
Linux 2.6.7
VIA C3 architechure

Hi. I have found a very interesting problem with the above setup. Icecast
starts up fine, but when I try to connect with iceS I get no response.

I've straced iceS and the last word comes from icecast, but waiting for
more. Icecast mentions nothing during this process, but show a quick
connect/lost connection when I Ctrl-C quit iceS.

I've tried different protocols (xaudiocast and icy headers) with iceS, and
changing the server_name in icecast from dynamic to the local resolved
hostname, no changes.

Icecast ran fine with a 2.4 kernel and non-VIA C3 optimizations, the only
problem I had was that a <defunct> icecast thread was added every time
iceS provided a new file to play.


Starting thread engine...
[29/Mar/2005:16:27:43] Icecast Version 1.3.12 Starting..
[29/Mar/2005:16:27:43] Starting Admin Console Thread...
-> [29/Mar/2005:16:27:43] Starting main connection handler...
-> [29/Mar/2005:16:27:43] Dynamic server name, using the local ip
-> [29/Mar/2005:16:27:43] Listening on port 8000...
-> [29/Mar/2005:16:27:43] Using '' as servername...
-> [29/Mar/2005:16:27:43] Server limits: 10 clients, 10 clients per
   source, 10 sources, 10 admins
-> [29/Mar/2005:16:27:43] WWW Admin interface accessible at
-> [29/Mar/2005:16:27:43] Starting Calender Thread...
-> [29/Mar/2005:16:27:43] Starting UDP handler thread...
-> [29/Mar/2005:16:27:43] Starting relay connector thread...
-> [29/Mar/2005:16:27:43] [Bandwidth: 0.000000MB/s] [Sources: 0]
   [Clients: 0] [Admins: 1] [Uptime: 1 seconds]


ices -b 128 -D /tmp -F /home/rojo/playlist.txt -m /ices -n 'Radio ITX' -P
'xxx' -R -r -s -S builtin -v -N 2

Logfile opened
DEBUG: Sending following information to libshout:
DEBUG: Stream: 0
DEBUG: Host: (protocol: xaudiocast)
DEBUG: Mount: /ices, Password: xxx
DEBUG: Name: Radio ITX  URL: http://www.icecast.org/
DEBUG: Genre: Default genre     Desc: Default description
DEBUG: Bitrate: 128     Public: 0
DEBUG: Dump file: (null)
DEBUG: Initializing playlist handler...
DEBUG: Initializing builting playlist handler...
DEBUG: Randomizing playlist...
DEBUG: Using LAME version 3.96.1
DEBUG: Builtin playlist handler serving:
DEBUG: Filename cleaned up from
to [01-daft_punk-human_after_all]
DEBUG: ID3v1: Title: human after all
DEBUG: ID3v1: Artist: Daft Punk
DEBUG: Trimmed file to 7668087 bytes
DEBUG: MPEG-1 layer III, 192 kbps, 44100 Hz, j-stereo
DEBUG: Ext: 0   Mode_Ext: 2     Copyright: 0    Original: 1
DEBUG: Error Protection: 0      Emphasis: 0     Padding: 0
DEBUG: Updated metadata on /ices to: Daft Punk - human after all
DEBUG: Grew output buffer to 59040 bytes

Icecast says nothing at this stage, and iceS stands still (no process
active). I press Ctrl-C in iceS, and icecast replies:

-> [29/Mar/2005:16:40:41] Accepted encoder on mountpoint /ices from two.
   1 sources connected
-> [29/Mar/2005:16:40:41] Lost connection to source on mount /ices,
   waiting 30 seconds for timeout

Strace on iceS (end part):

connect(7, {sa_family=AF_INET, sin_port=htons(8000),
sin_addr=inet_addr("")}, 16) = 0
send(7, "SOURCE xxx /ices\nx-audioc"..., 219, 0) = 219
recv(7, "OK\r\n", 1024, 0)              = 4

and there is stands still.

Any ideas on what can be wrong? Suggestions for further debugging?


More information about the Icecast mailing list