[icecast] slow streaming

Michael Smith msmith at xiph.org
Wed Mar 17 15:15:32 PST 2004



On Thursday 18 March 2004 08:02, ianux wrote:
> hi,
> here is my configuration :
> I've got a NATed network through a linux box
> the icecast server is running on the router
> I'm running ices 2.0 beta 4 on my own box
> everything seems to work fine, BUT:
>  - I don't appear on yp directories (which are of course commented out in
> the icecast config file) even with my public IP address or a dyndns domain

That's what you'd expect, surely? If you have them commented out, it isn't 
MEANT to list on them. Also, you might have built icecast without yp support.

>  - the stream lags on the internet. Clients bufferize every ten seconds
> (with only one listener!) I resample the ogg stream on ices from 128kbps to
> about 48kbps but it changes nothing! is it due to the client which handles
> poorly ogg stream?

Could be a client problem. There's not enough info here to be sure, but 
icecast doesn't normally behave like that.

> Do I need more bandwith? I have xDSL with about 512K of upload bandwith
> with in fact 96-128K available for icecast. What is the needed bandwidth
> for every listener and for a standard quality ?
>

Well, if you're streaming at 48 kbps, then it's 48 kbps for every listener, 
obviously.

Mike

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list