[Icecast] SVN Icecast YP problem

Karl Heyes karl
Sun Jun 20 05:17:41 PDT 2004


On Sun, 2004-06-20 at 07:15, Geoff Shang wrote:
...
> The sysadmin had to trim the log to get space back, so the bit where it all
> started no longer appears.  But in the 4 hours of log I still have, the
> following line appears over 76 thousand times:
>
> [2004-06-19  22:27:52] EROR yp/send_to_yp YP add on
> http://www.oddsock.org/cgi-bin/yp-cgi failed: Server already exists
>
> There were also lots (over 80 thousand) of the following:
>
> [2004-06-19  22:38:56] EROR yp/send_to_yp connection to
> http://dir.xiph.org/cgi-bin/yp-cgi failed with "Connect failed; Operation
> now in progress"

I did apply a fix for this type of error a few weeks ago, so this
depends on when exactly you got the svn code. The messages "server
already exists" are down to icecast YP entries not being removed, that
should be fixed already.

> The latter doesn't really surprise me that much, since going to
> dir.xiph.org results in the default apache page, which suggests the Xiph
> directory server is not up.  The error in the log since I restarted is
> different, however:
>
> [2004-06-20  02:07:57] EROR yp/send_to_yp YP add on
> http://dir.xiph.org/cgi-bin/yp-cgi failed: (null)
>
> And since I'm also not getting the "server already exists" error several
> times a second anymore (I'm not getting it at all), I'm thinking there's
> something funky with SVN Icecast that got it acting weird.

The above (null) message also requires a minor fix for error message
display. It's null as the YP operation failed but didn't actually send
an error message, however we do want something to be logged in such
cases so that action can be taken.

You should be able to comment out the YP section for dir.xiph.org and
send the HUP signal, adding it back in when the service comes back
later.

karl.




More information about the Icecast mailing list