[icecast] icecast2 can not log

dave dmehler26 at woh.rr.com
Fri Apr 2 04:07:50 UTC 2004

    I'm trying to setup icecast2 and darkice on a FreeBSD test system prior
to putting it in to production use. I've downloaded and installed the ports
for both without a problem, created directories logs and conf within the
icecast root which is /usr/local/share/icecast, and created an icecast user.
Then i edited /usr/local/share/icecast/conf/icecast.xml, the relevant
entries are:

  <!-- basedir is only used if chroot is enabled -->

        <!-- Note that if <chroot> is turned on below, these paths must both
             be relative to the new root, not the original root -->

       <loglevel>4</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->


When i try to start icecast i get a message, changed root successfully to
/usr/local/share/icecast, changed uid to 81, changed groupid to 81. And
"Fatal can not open access.log"
"Fatal could not open error.log"
"Fatal: could not start logging"
My start command is icecast -c /usr/local/share/conf/icecast.xml. Firstly, i
verified that the logs directory did exist then i changed it's owner and
group to icecast, and tried another restart. I then tried again with the
same results. I then went in to logs and touch both access.log and error.log
and changed there owner and group to icecast. Another restart and i got the
same error message. Any suggestions welcome.
Some urgency!

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.

More information about the Icecast mailing list