[icecast] compiler warning

Karl Heyes karl at xiph.org
Thu Nov 20 10:23:47 PST 2003



On Thu, 2003-11-20 at 18:05, Lukas Österreicher wrote:
> Hi again.
> 
> I just compiled icecast 2.
> It seemed ok but at the end I got this:
> 
> /usr/bin/ld: warning: libcom_err.so.2, needed by /usr/lib/libcurl.so, may conflict with libcom_err.so.3
> 
> Is this anything I have to take care of?
> Can you explain what it means?

The icecast you have built is relying on other libs, and there's
mismatch between 2 of them.

the /usr/lib/libcurl.so wants libcom_err.so.3 but something else wants
an older version of libcom_err.so.  Use ldd on your icecast and the libs
it wants, one will need to be updated to remove the warning.

karl.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list