[icecast] My turn to have issues with compiling libshout

Karl Heyes karl at pts.tele2.co.uk
Thu Mar 13 16:56:50 PST 2003



On Thu, 2003-03-13 at 23:28, Geoff Shang wrote:

> > This is the key point, what system is this, and can you send me the
> > config.log
> 
> This system is running Debian unstable and has the following auto*
> versions:

I'm currently in the process of changing the setup for using rwlock_t,
not all systems have them (they are a later posix spec) and are only
used by one module (avl).

The configure found the right flags to use but the make didn't use it,
so maybe try the recent checkins and if it's still a problem then send
me the config.log and libshout/avl/Makefile

> automake (GNU automake) 1.4-p6
> autoconf (GNU Autoconf) 2.57
> 
> Unstable has automake 1.4, 1.5, 1.6 and 1.7 available.  Is this the likely
> problem and is there a suggested version to upgrade to?

well brendan is thinking of making 1.6 the pre-requisite as the earlier
versions had various problems. I don't know what those problems are, but
many people have complained about them, so it's not beyond the realms of
possibilities that this could be biting you.

karl.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list