[icecast] libxml error (or am I just being dumb?)

Geoff Shang gshang at uq.net.au
Wed Mar 5 13:54:36 PST 2003



On 5 Mar 2003, Hans Huberland wrote:

> The follwing are installed by RPM:
> libxml2-2.4.23-1
> libxml2-devel-2.4.23-1
> libxml-devel-1.8.14-2
> libxml-1.8.14-2
> libxslt-1.0.7-2
> libxslt-devel-1.0.7-2

I'm pretty sure you need a newer libxslt than this.  Don't know what the
minimum is, but I have 1.0.16.

> encode.c: In function `encode_initialise':
> encode.c:91: storage size of `ai' isn't known
> encode.c:92: `OV_ECTL_RATEMANAGE_GET' undeclared (first use in this
> function)
> encode.c:92: (Each undeclared identifier is reported only once
> encode.c:92: for each function it appears in.)
> encode.c:96: `OV_ECTL_RATEMANAGE_SET' undeclared (first use in this
> function)
> encode.c:101: `OV_ECTL_RATEMANAGE_AVG' undeclared (first use in this
> function)
> make[2]: *** [encode.o] Error 1

What version of libvorbis do you have installed?  These are vorbis
items.

Geoff.

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list