[icecast] problems streaming ogg with ices2 and icecast2

Nigel Lupton luptonn at hotmail.com
Thu Dec 4 03:03:45 PST 2003



Hi there,

I'm trying to stream audio from my audio card using ices2/icecast2.  I've 
been following the unofficial HOWTO at 
http://www.6809.org.uk/media/ices2-howto.shtml.  So, I've downloaded and 
installed libshout2, ices2 and icecast2.

Everything starts up OK and I can get stats by pointing my browser at the 
admin page:

  <?xml version="1.0" ?>
- <icestats>
  <client_connections>5</client_connections>
  <connections>8</connections>
  <source_connections>3</source_connections>
  <sources>0</sources>
- <source mount="/test.ogg">
  <audio_info>samplerate=22050;channels=2;bitrate=64</audio_info>
  <bitrate>64</bitrate>
  <channels>2</channels>
  <public>0</public>
  <samplerate>22050</samplerate>
  <type>Ogg Vorbis</type>
  </source>
  </icestats>

However, if I try to get at the stream by pointing the browser at /test.ogg 
I get a 404 error.

I've tried saving the stream using the <savefile> tag in the ices.xml config 
file.  This file is always 0 bytes long.

Has anybody seen this before?  I'm running redhat/fedora core1.

Thanks,

Nigel.

_________________________________________________________________
Use MSN Messenger to send music and pics to your friends 
http://www.msn.co.uk/messenger

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list