[icecast] Icecast in Macromedia Flash

Michael Smith msmith at xiph.org
Mon Dec 1 16:40:58 PST 2003



> I'm sure Icecast (unlike Shoutcast) doesn't care what user-agent string
> is provided. If the stand-alone player works without modified headers,
> this can't be the problem.

This is correct: we send a user-agent header (for compatibility with shoutcast 
when doing relaying), but the only thing we do with that header is report it 
when requested (including logging).

> Here's a thought.
> Perhaps the embedded player is missing the relevant codec (MP3 decoder)
> to play the stream? Have you tried including a short, static MP3 at the
> start of the animation? My hopeful guess is that the embedded version is
> being 'compiled' without the MP3 decoder. If you force the encoder to be
> included (by adding a short static mp3 file at the start) it might know
> what to do with the stream once it gets it.
> Maybe even simply adding '.mp3' to the end of the mountpoint name (do
> this in the source client configuration) will force it to work.

I believe he said he tried it with icecast 1.x and it worked - this is very 
strange, to say the least. Without detailed network dumps, it's hard to even 
guess at what might be being done differently.

Mike

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list