[icecast] Difficulties with Ices2

Matthew Fields lugar at lugar.homeip.net
Tue Aug 5 13:22:51 PDT 2003



I have been successful in running a playlist through Ices and Icecast...
I have run into difficulty running a live stream through the soundcard,
however...

The following is the log when I attempt to run ices ices-mylive.xml:

INFO ices-core/main ices started...
EROR input-oss/oss_open_module Couldn't set sample format to AFMT_S16_LE
EROR input/input_loop Couldn't initialise input module "oss"
INFO ices-core/main Shutdown complete

Contents of the ices-mylive.xml:

<?xml version="1.0"?>
<ices>
    <background>0</background> <!-- run in background? (unimplemented) -->
    <logpath>/usr/local/icecast</logpath> <!-- where logs, etc go. -->
    <logfile>/usr/local/icecast/logs/ices.log</logfile>
    <loglevel>4</loglevel> <!-- 1=error,2=warn,3=info,4=debug -->
    <consolelog>1</consolelog>
        <!-- set this to 1 to log to console of file above -->
    <stream>
        <!-- metadata used for stream listing (not currently used) -->
        <metadata>
            <name>Radio Free Linux</name>
            <genre>Talk Radio</genre>
            <description>Radio Free Linux - Your Source for Open
Source</description>
        </metadata>
        <input>
            <module>oss</module>
            <param name="rate">11000</param> <!-- samplerate 22050 best-->
            <param name="channels">1</param> <!-- number of channels -->
            <param name="device">/dev/dsp</param> <!-- audio device -->
            <param name="metadata">0</param>
            <param name="metadatafilename">test</param>
        </input>
        <instance>
            <hostname>10.20.20.92</hostname>
            <port>8000</port>
            <password>xxxxx</password>
            <mount>/radiofree.ogg</mount>
            <reconnectdelay>2</reconnectdelay>
            <reconnectattempts>5</reconnectattempts>
            <maxqueuelength>80</maxqueuelength>
            <encode>
                <nominal-bitrate>16000</nominal-bitrate>
                    <!-- bps. e.g. 64000 for 64 kbps -->
                    <!-- bps. e.g. 32000 optimal for lesser cards -->
                <samplerate>11000</samplerate>
                    <!-- 22050 optimal for older cards -->
                <channels>1</channels>
            <quality>1</quality>
            </encode>
        </instance>
    </stream>
</ices>

The config is pretty simple, a SuSE 8.0 box.  Soundcard is a SB Pro 2
using OSS.

Any suggestions would be appreciated!!!

Thanks!

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list