[icecast] ices & savefile

Matt Trim matt at sv.net.au
Tue Aug 5 08:00:05 PDT 2003



Got it all compiled nicely.. I called it ices2 so I can keep using my
existing ices executable as well..

Tried getting it up and running but it seems to be having trouble
connecting to my soundcard.. sample from ices.log

[root at darkice root]# less ices.log
[2003-08-06  01:11:09] INFO ices-core/main Streamer version IceS 2.0-kh35
[2003-08-06  01:11:09] INFO ices-core/main libshout version 2.0-kh19
[2003-08-06  01:11:09] INFO ices-core/main Unable to set realtime
scheduling
[2003-08-06  01:11:09] INFO input-oss/oss_init_module Module OSS
initialised
[2003-08-06  01:11:09] DBUG input/initialise_input_modules Module 1 (OSS)
has 12 buffers
[2003-08-06  01:11:09] DBUG stream/check_for_runners starting runner
[2003-08-06  01:11:09] INFO stream/ices_runner Runner 1 ready
[2003-08-06  01:11:09] DBUG stream/check_for_runners starting runner
[2003-08-06  01:11:09] INFO stream/ices_runner Runner 2 ready
[2003-08-06  01:11:09] DBUG input/open_next_input_module checking module 1
[2003-08-06  01:11:09] INFO input-oss/oss_open_module Opened audio device
/dev/dsp at 1 channel(s), 44100 Hz
[2003-08-06  01:11:09] EROR input-oss/oss_read Error reading from audio
device: Resource temporarily unavailable
[2003-08-06  01:11:09] INFO input/input_loop Closing input module
[2003-08-06  01:11:09] INFO input-oss/oss_close_module Closing OSS module

eventually giving:

[2003-08-06  01:12:04] WARN input/open_next_input_module Too many failures
on input module 1 (OSS)
[2003-08-06  01:12:04] DBUG input/input_loop All input stopped, shutting
down.
[2003-08-06  01:12:04] DBUG stream/runner_close Runner thread 1 shutting
down
[2003-08-06  01:12:04] DBUG stream/runner_close Runner thread 2 shutting
down
[2003-08-06  01:12:04] DBUG stream/ices_runner Runner thread 2 cleaning up
streams
[2003-08-06  01:12:04] DBUG stream/ices_runner Runner thread 2 finshed
[2003-08-06  01:12:04] DBUG stream/ices_runner Runner thread 1 cleaning up
streams
[2003-08-06  01:12:04] DBUG stream/stream_cleanup Cleanup of stream 1
required
[2003-08-06  01:12:04] DBUG stream/stream_cleanup Cleanup of stream 2
required
[2003-08-06  01:12:04] DBUG stream/ices_runner Runner thread 1 finshed
[2003-08-06  01:12:04] DBUG input/free_modules freeing up module storage
[2003-08-06  01:12:04] INFO ices-core/main Shutdown in progress

<p>With the CVS ices however:

[2003-08-06  01:13:14] INFO ices-core/main ices started...
[2003-08-06  01:13:14] INFO input-oss/oss_open_module Opened audio device
/dev/dsp at 1 channel(s), 44100 Hz
[2003-08-06  01:13:14] INFO input-oss/oss_open_module Started metadata
update thread
[2003-08-06  01:13:14] INFO audio/resample_initialise Initialised
resampler for 1 channels, from 44100 Hz to 22050 Hz
[2003-08-06  01:13:14] INFO encode/encode_initialise Encoder initialising
in VBR mode: 1 channel(s), 22050 Hz, quality 0.000000
[2003-08-06  01:13:14] INFO signals/signal_usr1_handler Metadata update
requested
[2003-08-06  01:13:15] INFO stream/ices_instance_stream Connected to
server: xstream1.com:8610/i1197.ogg

I checked and I definately didn't have the CVS ices running at the same
time.. I thought that might have been the problem but it wasn't! Hmmm...

Thanks for all your help Karl!

<p>--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list