[icecast] icecast-1.3.12 on SunOS

Titus v.d.Malsburg malsburg at cl.uni-heidelberg.de
Fri Sep 13 02:59:36 PDT 2002



Hello

I compiled icecast-1.3.12 on a box with uname -a: SunOS star19 5.6 
Generic_105181-31 sun4u sparc SUNW,UltraSPARC-IIi-cEngine.  The result 
works properly.  The problem is that the icecast process generates 100% 
cpu load even if no sources and no clients are connected.

If I trace the process using truss, I get the following:

...
open("/dev/zero", O_RDWR)                       = 1
mmap(0x00000000, 16384, PROT_READ|PROT_WRITE|PROT_EXEC, 
MAP_PRIVATE|MAP_NORESERV
E, 1, 0) = 0xEEBE0000
close(1)                                        = 0
mprotect(0xEEBE0000, 8192, PROT_NONE)           = 0
lwp_create(0xEF40FAF0, 0x00C0, 0xEEBE3E04)      = 6
lwp_continue(6)                                 = 0
lwp_create(0x00000001, 0x4000, 0xEF40FC8C)      = 0
lwp_schedctl(SC_STATE|SC_BLOCK, -1, 0xEEBE3D0C) = 0
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
...
many times
...
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
poll(0xEFFFD750, 1, 30)                         = 0
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
time()                                          = 1031909555
...
time()                                          = 1031909556
poll(0xEF4ABA88, 0, 500)                        = 0
time()                                          = 1031909556
recvfrom(2, 0xEF4AFBA0, 8191, 0, 0x00063F38, 0xEF4ADB9C) Err#11 EAGAIN
time()                                          = 1031909556
lwp_sema_post(0xEF4B1E78)                       = 0
lwp_sema_wait(0xEF4B1E78)                       = 0
lwp_mutex_unlock(0xEF56B280)                    = 0
lwp_mutex_lock(0xEF56B280)                      = 0
time()                                          = 1031909556
time()                                          = 1031909556
time()                                          = 1031909556
time()                                          = 1031909556
lwp_sema_post(0xEF4B1E78)                       = 0
lwp_sema_wait(0xEF4B1E78)                       = 0
lwp_mutex_unlock(0xEF56B280)                    = 0
lwp_mutex_lock(0xEF56B280)                      = 0
time()                                          = 1031909556

<p>... and so on.  As you can see the time() is called many times per 
millisecond.

Does anybody have an idea what the problem is and how it could be solved?

Thannk,
  Titus

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list