[icecast] IceS: compile problem with Python

Brendan Cully brendan at icecast.org
Sun Sep 1 16:22:00 PDT 2002



On Monday, 02 September 2002 at 03:01, no name wrote:
> Hello!
> 
> I can't compile IceS 0.2.3 with Python 2.2 (X86, Red Hat 
> Linux 7.3)
> 
> ====================================
> [root at radio ices-0.2.3]# ./configure --with-lame 
> --with-python=/usr/bin 
> --with-python-includes=/usr/include/python2.2 
> --with-python-libraries=/usr/lib/python2.2
> ====================================
> 
> Configure script tell me:
> 
> ====================================
> <....>
> checking for Python.h... yes
> checking for Py_Initialize in -lpython... no
> checking for Py_Initialize in -lpython2.2... no
> checking for Py_Initialize in -lpython2.1... no
> checking for Py_Initialize in -lpython2.0... no
> checking for Py_Initialize in -lpython1.6... no
> checking for Py_Initialize in -lpython1.5... no
> configure: error: Could not find the python library
> [root at radio ices-0.2.3]#
> ===================================
> 
> Any suggestions?

Leave out the --with-python-libraries line. The libraries are probably
in /usr/lib, not /usr/lib/python2.2. That is, if you've made sure to
install the python-devel rpm.

-b
--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list