[icecast] ICECAST STOPS AND THROWS OUT ALL STREAMS

Peter Steen peter.steen at ing-steen.se
Sun Oct 20 09:59:33 PDT 2002



Hi !

I am new to the list.

I have been using icecast togeahter with ices and live streamers for almost
a year now.
We have between 10 to 300 listeners, localsite and outside world.
It has not been troublefree, icecast was stable util a week ago, just
crashed and refused to work anymore. We upgraded in hope to get rid of
problems.
It worked for maby 24 hours and then it just stops by random after 5, 20
minutes or maby
it lasts for some day and two, then icecast throws out all streams.

Just after a crash we notoce that icecast which usally run in five
processes, have
started as maby 20 to 80 new processes. (ps -e | grep icecast)
Ices reencode all streams to 128 Kilobit/s on the fly.

In the logfiles we notice LOTS of Losing track of time messages.
We also notice that almost all directory touches fails.
In the logs we also can see that Icecast Connection Handler suddenly starts
to kick all streams, and the listeners to.

Icecast version 1.3.12
Ices version 0.2.3

Exherpt from icecast.log:

[18/Oct/2002:22:00:51] [14:Connection Handler] Kicking source 10
[localhost.localdomain] [Invalid Mount Point] [encoder], connected for 0
seco
nds, 0 bytes transfered. 0 sources connected
[18/Oct/2002:22:00:51] [14:Connection Handler] Kicking all 0 clients for
source 10
[18/Oct/2002:22:00:52] [15:Connection Handler] Kicking source 11
[localhost.localdomain] [Invalid Mount Point] [encoder], connected for 0
seco
nds, 0 bytes transfered. 0 sources connected
[18/Oct/2002:22:00:52] [15:Connection Handler] Kicking all 0 clients for
source 11
[18/Oct/2002:22:01:00] [16:Connection Handler] Kicking source 12
[localhost.localdomain] [Invalid Mount Point] [encoder], connected for 49710
days, 6 hours, 28 minutes and 15 seconds, 0 bytes transfered. 0 sources
connected
[18/Oct/2002:22:01:00] [16:Connection Handler] Kicking all 0 clients for
source 12
[18/Oct/2002:22:01:03] [17:Connection Handler] Kicking source 13
[localhost.localdomain] [Invalid Mount Point] [encoder], connected for 2
seco
nds, 0 bytes transfered. 0 sources connected

----
[20/Oct/2002:18:38:30] [1:Calendar Thread]
directory_touch_xa([yp.icecast.org:80]) completed...server id = -1
[20/Oct/2002:18:38:30] [1:Calendar Thread]
directory_touch_xa([yp.mp3.de:80]) completed...server id = 69
[20/Oct/2002:18:39:00] [1:Calendar Thread] ERROR: Losing track of time.. is
it xmas already? [1035131940 - 1035131940 == 0 <= 0]
[20/Oct/2002:18:39:12] [14:Connection Handler] Accepted client 10 from
[anneli.ing-steen.se] on mountpoint [/ices]. 2 clients connected
[20/Oct/2002:18:39:13] [4:Source Thread] Kicking client 2
[anneli.ing-steen.se] [Client signed off] [listener], connected for 24
minutes and 45 seconds, 23745968 bytes transfered. 1 clients connected
[20/Oct/2002:18:40:00] [1:Calendar Thread] ERROR: Losing track of time.. is
it xmas already? [1035132000 - 1035132000 == 0 <= 0]
[20/Oct/2002:18:41:00] [1:Calendar Thread] ERROR: Losing track of time.. is
it xmas already? [1035132060 - 1035132060 == 0 <= 0]
[20/Oct/2002:18:42:00] [1:Calendar Thread] ERROR: Losing track of time.. is
it xmas already? [1035132120 - 1035132120 == 0 <= 0]
[20/Oct/2002:18:42:40] [1:Calendar Thread]
directory_touch_xa([yp.icecast.org:80]) completed...server id = -1
[20/Oct/2002:18:42:48] [1:Calendar Thread]
directory_touch_xa([yp.mp3.de:80]) completed...server id = 69

Our system is a Dual PIII with 1 Gigabyte of memory and we run linux
kernel-2.4.19
on a RedHat 7.1 system.

Anyone whome know how to fix this problem.

Than you in advance!

//Peter Steen

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.




More information about the Icecast mailing list