[icecast] Encrypted password problem with icecast 1.3.11

Thomas Steiger Tom at riptech.com
Mon Nov 26 06:14:00 PST 2001



This is what I get when I do ldd on the icecast binary.

[root at gala bin]# ldd icecast
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x0ffb3000)
        libm.so.6 => /lib/libm.so.6 (0x0ff65000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0ff2e000)
        libc.so.6 => /lib/libc.so.6 (0x0fde9000)
        /lib/ld.so.1 => /lib/ld.so.1 (0x30000000)
[root at gala bin]#

It looks like the libcrypt is there alright. I guess that I am still
wondering how the encryption can work if the mkpasswd program does not
produce the same results every time? Thoughts?

Tom

-----Original Message-----
From: Jerome Alet [mailto:alet at unice.fr]
Sent: Monday, November 26, 2001 8:59 AM
To: 'icecast at xiph.org'
Subject: RE: [icecast] Encrypted password problem with icecast 1.3.11

On Mon, 26 Nov 2001, Thomas Steiger wrote:

> I have tried these steps and the encryption on the console still does not
> seem to validate? Any other thoughts? Thanks,

if you're on Linux, then:

$ ldd icecast 

hould list libcrypt as part of the linked libraries. 

If this is not the case then crypt support was not activated during
compilation for one reason or another (e.g. a typo in configure command
line) 

hth.

Jerome Alet

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list