[icecast] [Newbie Q] Relay to an Icecast server apparently not relaying?

Geoff Shang gshang at uq.net.au
Tue Jun 12 00:11:25 PDT 2001



Hi:

Let me see if I understand what you're doing.  You're using winamp (or
whatever) to stream to a shoutcast server which pushes a relay on to
live365 (or live365 pulls from shoutcast, same deal really).  Now you've
got a second winamp with samcast trying to pull shoutcast or live365 and
pass it to icecast.  Is that right?

OK.  Firstly, there is no source connecting to icecast.  The login you are
seeing is an admin login.  Now, this plugin might do that for some reason,
but the fact remains that there's no actual source.  This is why the client
gets kicked as in the error message.

I don't know SAM so I can't comment there, and that would appear to be
where your problem is since it looks like it's not even trying to connect
as a source.

Having said all that, you can get icecast itself to pull a relay by
aliasing a mountpoint to the remote stream.  The neat thing about doing it
this way is that (A) you don't need another source to do the relaying and
(B) icecast doesn't pull unless there's one or more clients to listen to
it.

The format for aliasing is:

alias <mountpoint> <A HREF="http://<server">http://<server</A>>:<port>

for example:

alias relay http://shoutcast.myserver.com:8000

Will give anyone who connects to your machine on the /relay mountpoint the
stream that can be heard at http://shoutcast.myserver.com:8000.

Hope this helps.

Geoff.

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list