[icecast] XML parser for icecast2

Jack Moffitt jack at icecast.org
Mon Jun 4 09:00:46 PDT 2001



> I just checked out icecast2 from the bitkeeper repository.  But the
> compiler is halting on src/config.c where it's trying to include
> gnome-xml/xmlmemory.h and gnome-xml/parser.h.  Can someone tell me which
> lib I need for these files?

libxml 1.8.10 or better, or 2.0 or better.

a lot of systems have 1.8.9.  For the beta release, either will work,
but I haven't added the compatibility functions yet.

The reason this happens is that they wanted 2.0 apps to be written, so
they added the 2.0 api to 1.8.10 and later.  That way, you could write
apps to the stable versions, that would later run without change on the
latest and greatest.

Unfortunately, while this was a pretty good move I think, none of the
software distributors (besides Ximian GNOME) ever upgraded to libxml
1.8.10, so lots of people started writing libxml2 api code, which of
course broke everywhere.

It's fairly easy to make it compatible, though, so there's no reason not
to.

jack.

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list