[icecast] solaris success??

Hermann Schwaerzler Hermann.Schwaerzler at uibk.ac.at
Sat Jul 7 01:38:46 PDT 2001



hello

On Fri, 6 Jul 2001, Brendan Cully wrote:

> Alright, I've reencoded some music at 32kpbs mono 22050Hz and I can
> reproduce this problem on Solaris (but not on Linux). My first guess
> is there may be some non-LP64-safe code in the MP3 frame parser in
> libshout. I'll let you know what I find...

it might be totally unrelated, but a few days ago I had a similar problem:
I wanted to do some livestreaming from a windows machine using oddsocks
oddcast DSP (http://www.oddsock.org) to stream to 1.3.10 icecast-server on
linux.

I chose 24kpbs mono at 22050 Hz and at first tested it in 
win95. everything worked fine. 
when I tried to do the livestreaming on the "broadcasting" I had to
use win98 (german edition). there the problem occured: the stream was very
distorted and at least twice as fast as it should have been. I tried the 
same using the shoutcast DSP. same effect. 

My conclusion was: this is an error in win98 reading from the soundcard or
something like that. I did not try to find out more, because I do not like
windows. normally I do livestreaming with linux and liveice, but this time
I was unable to get a linux box so I had to use the win98 one...

o maybe there is some problem in the icecast-server with these settings
(22050 Hz, mono, low bitrate)?

hermann

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list