[icecast] Too many "too many errors"

Dave Hayes dave at jetcafe.org
Tue Apr 3 17:41:50 PDT 2001



Let me explain more of my testing.

I take the same laptop (a cheap compaq). I point winamp at my icecast
server, which is one hop away (frame relay T1). After 30-40 min I get
stuttering and eventual disconnect.

I point same winamp on same laptop to random icecast server(s). It's
fine for more than 2 hours, at a higher bitrate even. (I am
broadcasting at 40kb, I tested rates at 96 and 128kb.)

Somehow, I must be doing something wrong. I've checked the OS (FreeBSD 
4.2), the net.inet.tcp.sendspace (128k), and the icecast binary. Only
thing I can possibly see is "CHUNKSIZE" being set to 64. 

> So I assume that you're computer is fast enough to do this without
> problems? Is it a dedicated machine?   Does the source ever lose its
> connection, or just the clients

It's a win95 box, dedicated. The source never loses connection, and I
relay the source through an icecast relay on another machine. So:

line in --> win 95 box --> icecast (relay) --> icecast --> (world)

For what it's worth, connecting to the icecast (relay) above doesn't
exhibit these problems.
------
Dave Hayes - Consultant - Altadena CA, USA - dave at jetcafe.org 
>>> The opinions expressed above are entirely my own <<<

There are students who are in chains when they go to a teacher, and
the teacher adds another chain. The students are delighted, unable to
discern one thing from another. This is called a guest looking at a
guest.                                               -Zen Master Linji

--- >8 ----
List archives:  http://www.xiph.org/archives/
icecast project homepage: http://www.icecast.org/
To unsubscribe from this list, send a message to 'icecast-request at xiph.org'
containing only the word 'unsubscribe' in the body.  No subject is needed.
Unsubscribe messages sent to the list will be ignored/filtered.



More information about the Icecast mailing list