[flac-dev] Beginner's question

Johnny Rosenberg gurus.knugum at gmail.com
Fri Feb 8 11:31:43 PST 2013

I have just found out about the libflac thing and I have searched a
bit for information about it. I found its API and two examples.
My operating system is Ubuntu 12.04 and I installed the libflac-dev
thing from the software center (which is equal to installing it with
”sudo apt-get install libflac-dev”.

Is there anything more that I need to install to be able to compile,
for instance, the example atthe following place?

Since I'm not a very good programmer I just want to compile an
existing example, then experiment with it a bit (add and remove stuff
to the example, just to learn and get ideas), but it seems like I need
more than the libflac-dev package and the c-file on the above

I'm not very familiar with creating projects with dedicated IDEs, so
far I only use a simple text editor and I want to keep it that way for
a while, if possible.

I found a similar thread by searching, but the answer was somewhat
confusing to me, sorry for being an idiot.


Johnny Rosenberg

More information about the flac-dev mailing list