[Flac-dev] non-PIC code in shared libs again

Matt Zimmerman mdz at debian.org
Tue Feb 11 08:14:03 PST 2003

On Tue, Feb 11, 2003 at 07:55:37AM -0800, Ben Hines wrote:

> The patch fixed the problem with your libs. However, when linking the 
> xmms plugin i still get:
> *** Warning: This library needs some functionality provided by -lstdc++.
> *** I have the capability to make that library automatically link in 
> when
> *** you link to this library.  But I can only do this if you have a
> *** shared version of the library, which you do not appear to have.

Hmm...can you post the libtool command line and resulting gcc command line
which caused this message?  I did not think any C++ code was linked into the
xmms plugin, but that may have changed since I last looked at it.

 - mdz

More information about the Flac-dev mailing list