[theora] Encoding from fifo's

Dan Miller dan at on2.com
Tue Feb 4 17:54:13 PST 2003

the alpha is about as far from an optimized player as you can get.  It's all C, there is lots of buffer copies, and no effort has yet been made to make sure all cards are getting YUV overlays, etc.
If you're concerned about how this will perform, look at the original VP3 codecs instead.

        -----Original Message----- 
        From: Cameron Kerr [mailto:cameron.kerr at paradise.net.nz] 
        Sent: Mon 2/3/2003 7:42 PM 
        To: theora at xiph.org 
        Subject: Re: [theora] Encoding from fifo's

        On Mon, Feb 03, 2003 at 10:18:01AM -0700, emaillist+ot at dogphilosophy.net wrote:
	> The work-around for me was to use TWO mplayer instances - one exporting only
	> the audio and another exporting only the video.  That seemed to get it going.
        Alas, the encode plays back terribly on my PIII 800 system, although
        there are no artifacts (quality looks damn fine actually), the playback
        speed is just not suitable. I got large frequent slowdowns in playback,
        a little like someone who suffers from stuttering (but without the
        I tried encoding the same source (a dvd), in Vorbis+Theora, and again in
        MP3+MPEG4. These are the commands I used
        cd /tmp/
        mkfifo audiodump.wav
        mkfifo stream.yuv
        mplayer -dvd 2 -vo yuv4mpeg -au null &
        mplayer -dvd 2 -vo null -au pcm &
        encoder_example -a 2 -v 5 stream.yuv audiodump.wav > test.ogm
        It didn't get it all done however, I had errors from mplayer such as the
        Too many audio packets in the buffer: (4096 in 8257536 bytes).
        Maybe you are playing a non-interleaved stream/file or the codec failed?
        For AVI files, try to force non-interleaved mode with the -ni option.
        I then repeated the experiment with mencoder
        mplayer -dvd 2 -vo yuv4mpeg -au null &
        mplayer -dvd 2 -vo null -au pcm &
        mencoder -o test.avi -ovc lavc \
                -lavcopts vcodec=mpeg4:vbitrate=1800:vhq \
                -oac mp3lame -lameopts preset=standard \
                -audiofile audiodump.wav stream.yuv
        Which plays back fine. I still get the errors from mplayer however.
        I also tried extracting the audio first to a seperate file, then reading
        the video in a seperate pass straight from the dvd (via mplayer). This
        gave the same (unsuitable in Theora) results, but managed to encode the
        entire input.
        Any ideas why I get these mysterious stalls? Both encoders seem to be
        doing about the same fps (~8fps).
        Cameron Kerr
        Email:   cameron.kerr at paradise.net.nz
        Website: http://nzgeeks.org/cameron/
        --- >8 ----
        List archives:  http://www.xiph.org/archives/
        Ogg project homepage: http://www.xiph.org/ogg/
        To unsubscribe from this list, send a message to 'theora-request at xiph.org'
        containing only the word 'unsubscribe' in the body.  No subject is needed.
        Unsubscribe messages sent to the list will be ignored/filtered.

.+-j·!Š÷¬†Ûiÿü0醊àýªÜ†+Þ:)®ˆÞrØh™êZèm¶ŸÿÃ1Š˜h®èN‹§²æìr¸›yúèšØb²X¬¶Ç§u©ž²Æ zÚ-…ê+j·ª¹ë-Æ*ar‰íj)âž
+véì¹»®&ÞŠ{ayºÈÚ,¹¸ÞrجçR{.nÇ+‰·¦zˁë,z{m¢Ø^–+-Â)emè žŠÞw÷â–׫

More information about the Theora mailing list