[Theora-dev] building theora

John Kintree jkintree at swbell.net
Sat Sep 11 15:05:48 PDT 2004

I ran into difficulty trying to follow J. Grant's lead in building theora with 
libogg-1.1.tar.gz, libvorbis-1.0.1.tar.gz, and libtheora-1.0alpha3.tar.gz.  
The problem occurred while building libvorbis-1.0.1.  J. Grant discovered 
that the cause of the problem was that I had downloaded all three files into 
a directory named "theora files."  The space in that directory name was the 
problem.  Renaming that directory to "theorafiles" solved it.  

I also had the link error with libvorbis-1.0.1 examples, and worked around it 
by commenting out the line 
LDFLAGS = -all-static
from libvorbis-1.0.1/examples/Makefile.

Also, while building libtheora-1.0alpha3, I got an error, unable to 
find /usr/lib/libogg.la and my workaround for that was to copy libogg.la 
from /usr/local/lib into /usr/lib.  

gcc (GCC) 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk)
GNU ld version 20031029

More information about the Theora-dev mailing list