[opus] Trying to use Opus in an STM32F429IIT6 embedded project

Ulisses Piassa ulisses.piassa at gmail.com
Mon Jun 5 12:28:49 UTC 2017

Hi everyone,

I'm trying to use Opus in an Embedded Project which I'm developing in a
STM32F429IIT6 microcontroller. Currently, I'm playing wav files in it.

I ported all the files from OpusLib 1.1.4 needed to compile the project,
but when I try to create and OpusDecode state, it returns the error -7

I'm compiling it with the USE_ALLOCA flag. I also tried to compile it with
'opus_free(x)=NULL', but still having no success.

The code I wrote is:

    int size;
    int error;
    OpusDecoder* dec;

    size = opus_decoder_get_size(1);
    dec = (OpusDecoder *) malloc(size);
    error = opus_decoder_init(dec, 8000, 1);

I also tried this code:

    int error;
    OpusDecoder *dec;
    dec = opus_decoder_create(8000, 1, &error);

In this particular case, I got an error and the firmware crashes.

Once I'm totally new to embedded systems, I'd like to ask some help from
you. Can anyone shed some light on it?

Thx a lot.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xiph.org/pipermail/opus/attachments/20170605/5a0142bb/attachment.html>

More information about the opus mailing list